Giter VIP home page Giter VIP logo

minecraft.nix's People

Contributors

chuangzhu avatar lheckemann avatar linyinfeng avatar ninlives avatar viluon avatar

Stargazers

 avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar

Watchers

 avatar  avatar  avatar  avatar  avatar

minecraft.nix's Issues

Running into error "error: value is a function while a list was expected" when trying to use the flake

Hello,

First off, thank you for this flake.

I'm new to flakes, so this might be a beginner's mistake on my side.

I am running on the following error when I try to use this flake in NixOS 21.11:

error: value is a function while a list was expected

       at /nix/store/cijly7m9alsipw3x5097hnz2ayw4lw3x-source/builder.nix:127:19:

          126|       final = evalModules {
          127|         modules = modules
             |                   ^
          128|           ++ [ ({ _module.args.pkgs = pkgs; }) (import ./module) ];
(use '--show-trace' to show detailed location information)

I invoke the flake with the following command:

NIXPKGS_ALLOW_UNFREE=1 nixFlakes run   --impure ".#v1_18_1.vanilla.client"

(The nixFlakes command comes from https://nixos.wiki/wiki/Flakes#Installation_as_an_extra_command)

I tried to modify line 127 of builder.nix so that modules becomes a list with the following "patch":

diff --git a/builder.nix b/builder.nix
index 930c86a..9ccb86e 100644
--- a/builder.nix
+++ b/builder.nix
@@ -124,7 +124,7 @@ let
   mkLauncher = modules:
     let
       final = evalModules {
-        modules = modules
+        modules = [ modules ]
           ++ [ ({ _module.args.pkgs = pkgs; }) (import ./module) ];
       };
     in final.config.launcher // {

I now run into the following error:

error: value is a list while a set was expected

       at /nix/store/0gcda509wdm9zchk4m0dn433aixi5300-source/lib/modules.nix:366:44:

          365|         options = {};
          366|         config = addFreeformType (addMeta (removeAttrs m ["_file" "key" "disabledModules" "require" "imports" "freeformType"]));
             |                         

I tried an earlier version of the repository (commit 3674454) and managed to run the flake correctly (it runs the script that asks for a MSA logon).

Do you have any ideas of what I'm doing wrong?

Best regards,
Tony

LWJGL2 crashes due to missing xrandr

Minecraft versions before 1.13 use LWJGL2 for graphics, which determines the existing graphics modes by parsing the output of the "xrandr" command. The launch scripts from this project explicitly clear the PATH, and the xrandr binary does not appear there. This makes it impossible to play the game on these versions, even if xrandr is installed on the system.

Java 19 incompatible with Minecraft 1.8.9

I came across this project today and it is looking quite neat!

When I tried to run the 1.8.9 version, the resulting program crashes every time I try to join hypixel.net (haven't checked other servers) with an error saying it can't access address of the buffer.

I managed to fix the issue by replacing the jre package in the module/client.nix file by the jre8 package. Apparently java 19 is too new? Could anyone provide insight in this?

Recommend Projects

  • React photo React

    A declarative, efficient, and flexible JavaScript library for building user interfaces.

  • Vue.js photo Vue.js

    ๐Ÿ–– Vue.js is a progressive, incrementally-adoptable JavaScript framework for building UI on the web.

  • Typescript photo Typescript

    TypeScript is a superset of JavaScript that compiles to clean JavaScript output.

  • TensorFlow photo TensorFlow

    An Open Source Machine Learning Framework for Everyone

  • Django photo Django

    The Web framework for perfectionists with deadlines.

  • D3 photo D3

    Bring data to life with SVG, Canvas and HTML. ๐Ÿ“Š๐Ÿ“ˆ๐ŸŽ‰

Recommend Topics

  • javascript

    JavaScript (JS) is a lightweight interpreted programming language with first-class functions.

  • web

    Some thing interesting about web. New door for the world.

  • server

    A server is a program made to process requests and deliver data to clients.

  • Machine learning

    Machine learning is a way of modeling and interpreting data that allows a piece of software to respond intelligently.

  • Game

    Some thing interesting about game, make everyone happy.

Recommend Org

  • Facebook photo Facebook

    We are working to build community through open source technology. NB: members must have two-factor auth.

  • Microsoft photo Microsoft

    Open source projects and samples from Microsoft.

  • Google photo Google

    Google โค๏ธ Open Source for everyone.

  • D3 photo D3

    Data-Driven Documents codes.