Giter VIP home page Giter VIP logo

k-redux-factory's People

Contributors

afaugeras avatar bpetetot avatar fabienjuif avatar frinyvonnick avatar greenkeeper[bot] avatar guillaumecrespel avatar

Stargazers

 avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar

Watchers

 avatar  avatar  avatar  avatar  avatar  avatar

k-redux-factory's Issues

Error middleware with v6.0

Hello,
I would like to migrate from 5.0.2 to 6.0 but I have this error when I define a middleware with helper mapPayload. This middleware worked with v5.0.2. Please help me :) because I would like to migrate for reduce my bundle.

Thanks.

Error :

Uncaught Error: Reducer "cities" returned undefined during initialization. If the state passed to the reducer is undefined, you must explicitly return the initial state. The initial state may not be undefined. If you don't want to set a value for this reducer, you can use null instead of undefined

Example :

import { combineReducers } from 'redux'
import { keyValue, simple } from 'k-redux-factory'
import { mapPayload } from 'k-redux-factory/helpers'

const path = 'data.analyse'

const mapCity = city => ({
  text: city.label,
  ...city,
})
const mapCities = cities => cities.map(mapCity)

const middlewares = {
  pre: [
    mapPayload(/@@krf\/SET>DATA.ANALYSE>CITIES/)(mapCities),
  ],
}

export const cities = keyValue(middlewares)({ path, key: 'value', name: 'cities', prefix: path, defaultData: [] })
export const establishments = keyValue({ path, key: 'id', name: 'establishments', prefix: path })
export const firstActs = keyValue({ path, key: 'value', name: 'firstActs', prefix: path })
export const hasConsented = simple.bool({ path, name: 'hasConsented', defaultData: false, prefix: path })
export const hasDevisChirurgie = simple.bool({ path, name: 'hasDevisChirurgie', defaultData: false, prefix: path })
export const modeConnecte = simple.bool({ path, name: 'modeConnecte', defaultData: false, prefix: path })
export const result = simple.object({ path, name: 'result', prefix: path })
export const secondActs = keyValue({ path, key: 'value', name: 'secondActs', prefix: path })

export default combineReducers({
  cities,
  establishments,
  firstActs,
  hasConsented,
  hasDevisChirurgie,
  modeConnecte,
  result,
  secondActs,
})

remove with instance object

Right now we can remove instance from keyValue per their key.
Add the possibility to remove them per reference equality to full instance.

pseudo code:

const = remove = ([object]) => {
  if (typeof object === 'object') {
    // remove per reference equality
  } else {
    // remove per id 
  }
}

API / simpleObject / defaultValue

What do you think to add the possibility to add defaultValue with the first parameter ?

function defaultValue
simpleObject() {}
simpleObject({ defaultValue: {} }) {}
simpleObject({ my: 'object' }) {}
simpleObject('string') 'string'
simpleObject([1, 2, 3]) [1, 2, 3]

Ramda style curryfication

Idea from @BenoitAverty

  • Use Ramda curryfication style and let user choose between those interfaces :
    • factory(key)(state)(name)
    • factory(key, state)(name)
    • factory(key, state, name)

Add the possibility to pass an array to all `keyValue` actions

Problem

We often have to update every values in a keyValue store. But with the current API, it can lead to a huge number of dispatched actions.

Proposition

I propose to make update, addOrUpdate and replace action polymorphic on their argument, allowing to pass an instance or an array of instances.

Example

import { keyValue } from 'k-redux-factory'

const store = keyValue({ key: 'id' })

store.addOrUpdate([
  { id: 1, value: '1' },
  { id: 2, value: '2' },
  { id: 3, value: '3' },
])

Change lib name ?

From @bpetetot

The librairy name doesn't speak itself... and is very long.
Does it be better to call it with factory in the lib name, like : redux-factory or trampss-redux-factory ?

Benefits of k-redux-factory selectors

Sometimes, accessing an object in the state from a container is quickier to write than using its selector.
I would like to know all the advantages of k-redux-factory selectors over the direct use the state.

An in-range update of microbundle is breaking the build 🚨

The devDependency microbundle was updated from 0.8.1 to 0.8.2.

🚨 View failing branch.

This version is covered by your current version range and after updating it in your project the build failed.

microbundle is a devDependency of this project. It might not break your production code or affect downstream projects, but probably breaks your build or test tools, which may prevent deploying or publishing.

Status Details
  • βœ… ci/circleci: debug: Your tests passed on CircleCI! (Details).
  • ❌ ci/circleci: lockfile: Your tests failed on CircleCI (Details).

Release Notes for 0.8.2
Commits

The new version differs by 13 commits.

See the full diff

FAQ and help

There is a collection of frequently asked questions. If those don’t help, you can always ask the humans behind Greenkeeper.


Your Greenkeeper Bot 🌴

README.md

Write to the README that the lib handle the immutability

Remove `orderBy`

I want to remove orderBy:

  • This is not the lib purpose
  • This is not performant
  • It takes some space to the bundle
  • It uses lodash function that are pain to rewrite
  • If you call orderBy, then add this is not ordered anymore

We could maybe add it later with a post middleware in helpers.

What are your thoughs ? @guillaumecrespel @EmrysMyrddin @bpetetot

Migrating guide

A new markdown that explain what you have to do to go from 5.X.X to 6.X.X

An in-range update of npm-run-all is breaking the build 🚨

The devDependency npm-run-all was updated from 4.1.3 to 4.1.4.

🚨 View failing branch.

This version is covered by your current version range and after updating it in your project the build failed.

npm-run-all is a devDependency of this project. It might not break your production code or affect downstream projects, but probably breaks your build or test tools, which may prevent deploying or publishing.

Status Details
  • βœ… ci/circleci: debug: Your tests passed on CircleCI! (Details).
  • ❌ ci/circleci: lockfile: Your tests failed on CircleCI (Details).

Commits

The new version differs by 3 commits.

  • a79fbac πŸ”– 4.1.4
  • d97929c remove test in version script temporary
  • 57d72eb πŸ”₯ remove ps-tree

See the full diff

FAQ and help

There is a collection of frequently asked questions. If those don’t help, you can always ask the humans behind Greenkeeper.


Your Greenkeeper Bot 🌴

add an initial state for data store

if I reset my state, state.path.data will be undefined

Maybe you could add an optional property in the factory to initalize the data :

factory()()()({ name: 'docgen', type: 'uniq', defaultData: {} })

Add middleware support

Our reducer should be like that (pseudo code) :

reducer = (state, action) => {
  let previous = [state, action]
  midlewares.forEach(middleware => middleware(state, action))
}

The lib will add the current reducer as a core middleware.
The user could add some of middlewares before and after core one.

With this pattern the user can change

  • the action before the core reducer (use case example: generate id #9)
  • the state (use case, add some event catching)

factory signature

Presently, this is boring to have middlewares in first function because 99% of times we don't use it.
So the signature is 99% of times this :
factory(/* middleware */)('id')('a.path')('aname')

How can we simplify that but let the user :

  • have a default middleware to export (overriding trampss-redux-factory)
  • change middleware with ease between each factory.

Prefix action types

From @bpetetot

To avoid having too generic actions names, you might should prefix the actions names like (and keep the upper case convention) : @trampss/SET_TODOS

Rename simpleObject for simpleValue

The name simpleObject is misleading. We expect that the value backed by this factory have to be an object. Perhaps we can make it more obvious by naming it simpleValue which more clearly indicate that this factory is backing any kind of value.

Add a generic `getBy`

reducer.getBy('a.path', [valeur1, valeur2])

todo : {
visible: false,
title: 'a',
id: 1,
}

reducer.getBy('visible', false)

API to add custom actions to state nodes

From @EmrysMyrddin (unirakun/k-ramel#60)


It could be useful to allow users to define their own custom actions along with the ones already generated by k-redux-factory.

The actions could be then decorated with dispatch function, allowing the user to easily call it from the store

const store = createStore({
  data: simpleObject({ 
    actions: {
      load: () => ({ type: 'REQUEST_DATA' }),
      loaded: (data) => ({ type: 'DATA_LOADED', payload: { data } }),
    },
  }),
})

store.data.loaded()
store.data.load({ hello: 'world' })

Since we want to push the use of the redux-saga like API, we want to be able to dispatch very simple action like simple events. For this, our library can also help the user by generating actions for him. You just give a type name for your action and it generate the action creator for you. The action creators can take an optional payload that will be aded to the action.

const store = createStore({
  data: simpleObject({
    actions: {
      load: 'REQUEST_DATA',
      loaded: 'REQUEST_DATA',
      // Also allows to give a custom action creator implementation
      custom: () => ({ type: 'CUSTOM_ACTION' })
    },
  }),
},{
  listeners: [
    when(store.data.load.type, (action, store) => store.data.loaded({ hello: 'world' }))
    // Dispatch { type: 'DATA_LOADED', payload: { hello: 'world' } }
  ]
})

I'm not entirely sure of the API. In particular, I'm not convinced by the store.data.load.type to get the type name of the action. Perhaps by adding a toString implementation to the function ? Allowing to just do when(store.data.loaded, (...) => ...) ?

combine selectors "getById" and "getDatas"

replace the selector getById([id]) and getDatas() by uniq selector get()

reducer.get() => return all datas
reducer.get(key) => return the data of key
reducer.get([key]) => return all datas of keys

help the developpers to detect that there is 2 reducer with same name/prefix

Only in development builds:

  • use a global variable to register all tuples (name, prefix)
  • detect if there is a collision
  • if there is a collision, print a warning (error ?) message, something like: [k-redux-factory] You combined two reducers with same name and prefix, we think this is a bug. You should look at 'prefix' option to create your reducer(s)!

@bpetetot are you ok ?

This is related to #73 that is coming back on a regular basis

API / Method names

From @bpetetot

It would be great to have methods to get action names.
It will avoid that reducers will depends on the lib actions names (which can change in the future.

Maybe we can write something like this :

const store = factory('name')
store.add.actionType()

remove data field from simpleObject

  • remove data from simpleObject
  • split selectors into types, in this case get will not be the same for simpleObject type and keyValue
  • I would see types/simpleObject/simpleObject.selectors.js

Version 6.0.0

Hey @bpetetot @EmrysMyrddin @frinyvonnick !

I would like to publish the stable release 6.0.0.
Are you ok with this release ?

The changes ares theses commits: 4224d84...master

There is a rc published with the next tag: yarn add k-redux-factory@next.
If you can test this new version on one of your own project it could be great :)

Thank to all of you.


I put a deadline to the next week so I can move on if I have no response.

Recommend Projects

  • React photo React

    A declarative, efficient, and flexible JavaScript library for building user interfaces.

  • Vue.js photo Vue.js

    πŸ–– Vue.js is a progressive, incrementally-adoptable JavaScript framework for building UI on the web.

  • Typescript photo Typescript

    TypeScript is a superset of JavaScript that compiles to clean JavaScript output.

  • TensorFlow photo TensorFlow

    An Open Source Machine Learning Framework for Everyone

  • Django photo Django

    The Web framework for perfectionists with deadlines.

  • D3 photo D3

    Bring data to life with SVG, Canvas and HTML. πŸ“ŠπŸ“ˆπŸŽ‰

Recommend Topics

  • javascript

    JavaScript (JS) is a lightweight interpreted programming language with first-class functions.

  • web

    Some thing interesting about web. New door for the world.

  • server

    A server is a program made to process requests and deliver data to clients.

  • Machine learning

    Machine learning is a way of modeling and interpreting data that allows a piece of software to respond intelligently.

  • Game

    Some thing interesting about game, make everyone happy.

Recommend Org

  • Facebook photo Facebook

    We are working to build community through open source technology. NB: members must have two-factor auth.

  • Microsoft photo Microsoft

    Open source projects and samples from Microsoft.

  • Google photo Google

    Google ❀️ Open Source for everyone.

  • D3 photo D3

    Data-Driven Documents codes.