Giter VIP home page Giter VIP logo

input-leap.nix's Introduction

Input Leap nix

This is Input Leap packaged with nix

This has successfully been run on the following configurations:

Server Client
macos sonoma on aarch64-darwin gnome 45/wayland on x86_64-linux

Build

nix build .

Then collect your app under ./result/Applications/InputLeap.app

Configure

On the server, choose Use existing configuration and use a configuration (~/input-leap.conf) that looks like the following:

section: screens
        ubu:
        mac:
end

section: links
        ubu:
                left = mac
        mac:
                right = ubu
end

Then start/reload.

On the client, set the Server IP to that of the server.

Then start, a dialog will appear, turn on Allow remote interaction and [Share].

You should now be able to use your mouse and keyboard across machines!

Resources

Things to ba aware of

  • The Configure Interactively function doesn't to work, editing the GUI fails.
  • The client needs to be logged in and the input leap GUI must be opened manually and started
  • Make sure no other synergy/barrier/input leap instance or similar is running
  • The clipboard doesn't work for me
  • CMD key doesn't work on the linux client
  • Focus doesn't leave the host, when interacting with the client. So the cursor and sometimes text gets selected on the host screen :/
  • If ~/input-leap.conf is invalid, the GUI may just crash

Troubleshooting

ERROR: invalid message from client "lowrey": DINF

The server's ~/input-leap.conf has an invalid configuration, confirm the configuration attributes are correct.

What's been evaluated

When looking for a KVM to use on macbook and a linux desktop...

  • Synergy was the original project, was using this with a windows client
    • Unfortunately, there's no installer yet for gnome/wayland/nix.
  • Barrier is a fork of Synergy appears unmaintained.
    • This was almost working, but there was no cursor on gnome/wayland.
    • It was unclear why it would stop working frequently
  • Input Leap is a fork of Barrier, the build was approachable.

Installation - via a flake

Add the following to your flake configuration

# flake.nix
{
    inputs = {
        # ...
        input-leap.url = "github:wav/input-leap.nix";
        # ...
    };
    
    outputs = inputs: {
        # ...
        overlays = [ inputs.input-leap.overlays.default ];
        # ...
    };
}

Add the package to your env

# configuration.nix
{ pkgs, ...}: {
    # ...
    environment.systemPackages = [ pkgs.input-leap ];
    # ...
}

Then rebuild. The desktop applications will now appear in your programs/applications.

input-leap.nix's People

Contributors

wav avatar

Watchers

 avatar  avatar

Recommend Projects

  • React photo React

    A declarative, efficient, and flexible JavaScript library for building user interfaces.

  • Vue.js photo Vue.js

    ๐Ÿ–– Vue.js is a progressive, incrementally-adoptable JavaScript framework for building UI on the web.

  • Typescript photo Typescript

    TypeScript is a superset of JavaScript that compiles to clean JavaScript output.

  • TensorFlow photo TensorFlow

    An Open Source Machine Learning Framework for Everyone

  • Django photo Django

    The Web framework for perfectionists with deadlines.

  • D3 photo D3

    Bring data to life with SVG, Canvas and HTML. ๐Ÿ“Š๐Ÿ“ˆ๐ŸŽ‰

Recommend Topics

  • javascript

    JavaScript (JS) is a lightweight interpreted programming language with first-class functions.

  • web

    Some thing interesting about web. New door for the world.

  • server

    A server is a program made to process requests and deliver data to clients.

  • Machine learning

    Machine learning is a way of modeling and interpreting data that allows a piece of software to respond intelligently.

  • Game

    Some thing interesting about game, make everyone happy.

Recommend Org

  • Facebook photo Facebook

    We are working to build community through open source technology. NB: members must have two-factor auth.

  • Microsoft photo Microsoft

    Open source projects and samples from Microsoft.

  • Google photo Google

    Google โค๏ธ Open Source for everyone.

  • D3 photo D3

    Data-Driven Documents codes.